The Phaserl


Impeach Obama Over Gitmo Release: The Hypocrisy of Sen. Lindsey Graham

by Kurt Nimmo, Infowars:

President Barack Obama has violated the Constitution on numerous occasions. Obamacare, executive orders, cybersecurity, NSA surveillance, backdoor legalization of illegal aliens, the Pakistan drone war and the invasion of Libya are all serious constitutional violations.

On Wednesday South Carolina Senator Lindsey Graham warned that he and his fellow lawmakers will call for Obama to be impeached if the president releases more detainees from Guantánamo Bay without congressional approval.

Article II, Section IV of the Constitution provides Congress with the vehicle to impeach a president for high crimes and misdemeanors.

“It’s going to be impossible for them to flow prisoners out of Gitmo now without a huge backlash,” Graham said. “There will be people on our side calling for his impeachment if he did that.”

Read More @

Help us spread the ANTIDOTE to corporate propaganda.

Please follow SGT Report on Twitter & help share the message.

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>